Jun 18, 2018 — Announcements, For DigitalChalk Users, Online Training Software

DigitalChalk TLS 1.0 Security Update

We want to let everyone know about an important DigitalChalk TLS 1.0 security update becoming effective June 30, 2018.

The technical run-down

Transport Layer Security (TLS) is a protocol that provides privacy and data integrity between two or more communicating computer applications.  Websites use TLS to secure all communications between their servers and web browsers.

Because the older TLS 1.0 protocol is considered less secure, all websites that transmit or processes credit card data are dropping support for TLS 1.0 in 2018.

To continue to maintain the highest level of data security, DigitalChalk will discontinue support of the older TLS 1.0 protocol as of June 30, 2018. Communication to and from DigitalChalk must be using the more secure TLS 1.2 (or TLS 1.1) protocol by that time. DigitalChalk will be operating as normal during this change.

So what does this mean in non-technical terms?

Your browser (and/or device) must support TLS 1.1 or TLS 1.2 to connect, login, and take courses through DigitalChalk after June 30, 2018. If you try to access DigitalChalk after June 30, 2018, and see only a blank screen, you most likely are using a browser that does not support TLS 1.1 or TLS 1.2.

How do I fix this?

Hopefully, you won’t see the blank screen!  If you currently use the most recent version of any major browser, the default setting is TLS 1.1 or higher.

But if you do get the blank screen there are a couple of things you can try.  Make sure you are using the most current version of your browser or switch to a more recent browser.  If you are not able to use a more recent browser, you might be able to update the settings in your current browser to allow a more secure connection.  Steps for updating older versions of Internet Explorer are provided here.

Update Microsoft Internet Explorer settings

Microsoft Internet Explorer versions 8, 9, and 10 default settings must be changed to the more secure TLS 1.1 and TLS 1.2 protocols.

  • Check Use TLS 1.1 and Use TLS 1.2 to change the default browser setting to TLS 1.1/TLS 1.2.
  • Make sure Use SSL 2.0, Use SSL 3.0, and Use TLS 1.0 are unchecked.
  • Click OK.


Verify your security settings

  • Restart your browser before attempting to verify your settings.
  • Follow this link: Qualys SSL Labs
  • You’ll see a Protocol Support report for your browser telling you whether or not it supports TLS 1.1 and/or TLS 1.2.

A note on operating systems

Windows Vista and older operating systems, such as Windows XP, are not compatible with TLS 1.1 or higher protocols, regardless of the browser. For data security reasons, DigitalChalk can no longer support any browser on these operating systems.

If you have questions or need more help

The purpose of this email is to explain the TLS security update in non-technical terms, but if you’d like a more technical explanation, we have that too.

And as always, we are available to answer any questions you might have.  Simply call 877-321-2451 (option 2) or email support@digitalchalk.com.

Please feel free to share this email with any of your customers who may need assistance updating their browser.

 

Thank you for working with us to ensure the security and privacy of your DigitalChalk data.

The DigitalChalk Team